develooper Front page | perl.perl5.porters | Postings from December 2004

Re: On the subject of CPAN indexing and the wrong modules being presentedfor upgrade

Thread Previous
From:
Stas Bekman
Date:
December 23, 2004 19:46
Subject:
Re: On the subject of CPAN indexing and the wrong modules being presentedfor upgrade
Message ID:
41CB910A.3080108@stason.org

> command 'r' still shows the following:
> 
> Package namespace         installed    latest  in CPAN file
> B                              1.02      1.07  
> N/NW/NWCLARK/perl-5.8.6.tar.gz
> 
> So that's not it.  I'm not saying this is fixable, just that I noticed 
> it as a discrepancy...

There is no problem here. B exists only in the core, 5.8.6 has a higher 
version so CPAN.pm shows it. Removing it from the index will be a wrong 
thing to do, IMHO, since if someone wants to check whether a newer version 
is available they won't be able to tell.

I believe you are confusing that with a special case fix in the PAUSE 
indexer that favors the real distro for dual-life CPAN modules rather than 
the bundled with perl-core version.


-- 
__________________________________________________________________
Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker
http://stason.org/     mod_perl Guide ---> http://perl.apache.org
mailto:stas@stason.org http://use.perl.org http://apacheweek.com
http://modperlbook.org http://apache.org   http://ticketmaster.com

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About