develooper Front page | perl.perl5.porters | Postings from December 2003

Re: POSIX smoke errors on Solaris

From:
Andy Dougherty
Date:
December 16, 2003 08:17
Subject:
Re: POSIX smoke errors on Solaris
Message ID:
Pine.SOL.4.58.0312161115060.17001@maxwell.phys.lafayette.edu
On Mon, 15 Dec 2003, Alan Burlison wrote:

> [sorry for the dup, I blame Mozilla :-)]
>
> I'm getting the following errors for 5.6.x, 5.8.x and 5.9.x building on
> Solaris 2.6, 2.7, 2.8, 2.9 & 2.10.  The subsequent 'make test' runs all
> seem to pass the POSIX bits OK.
>
> Can't locate auto/POSIX/autosplit.ix in @INC (@INC contains: ../../lib
> /opt/lib/perl5/5.8.2/sun4-solaris /opt/lib/perl5/5.8.2
> /opt/lib/perl5/site_perl/5.8.2/sun4-solaris
> /opt/lib/perl5/site_perl/5.8.2 /opt/lib/perl5/site_perl .) at
> ../../lib/AutoLoader.pm line 160.
>   at POSIX.pm line 7
>
> I suspect this is a smoke harness problem as I don't see it when I
> hand-build.

No, it's a generic problem.  You'll see it anytime you try to build if
there's no auto/POSIX/autosplit.ix available anywhere else along @INC.
I think I've even got an entry for it in bug database dating from shortly
before 5.8.0's release.

It's harmless.

I vaguely recall it might have to do with MakeMaker trying to check
versions or something, but I really don't remember.

-- 
    Andy Dougherty		doughera@lafayette.edu



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About