develooper Front page | perl.perl5.porters | Postings from October 2003

Re: new slurp module

Thread Previous | Thread Next
Elizabeth Mattijsen
October 23, 2003 09:28
Re: new slurp module
Message ID:
At 15:31 +0000 10/23/03, Peter Scott wrote:
>In article <>,
> (Michael G Schwern) writes:
>>I like the term slurp.  Larry likes it, too, IIRC.  You should
>>alias read_file() to slurp() and export it.  spew()'s not a bad name
>  >either for write_file().
>My vote is for burp() (I suggested it to Uri while he was writing 
>his article).
>It's less visceral and it rhymes with slurp().  I don't want to feel
>nauseated while writing Perl, I read enough nauseating Perl as it is.
>Next thing you know there'll be more powerful routines like vomit(),
>puke(), blow_chunks(), and a Perl program will look like the Crunchy Frog
>sketch.  Go with burp() and the farthest you can go down that road will
>be belch() and eructate().

I always have used "splat" as the opposite to "slurp" in my 
particular implementation of this functionality.


Thread Previous | Thread Next Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About