develooper Front page | perl.perl5.porters | Postings from October 2003

Re: [perl@21451] t/io/openpid.t tests fail on Win32 with :stdio

Thread Previous | Thread Next
From:
Abe Timmerman
Date:
October 15, 2003 10:15
Subject:
Re: [perl@21451] t/io/openpid.t tests fail on Win32 with :stdio
Message ID:
200310151924.31792.abe@ztreet.demon.nl
Op een wisselvallige herfstdag (Wednesday 15 October 2003 15:15), schreef 
Steve Hay:

> The t/io/openpid.t tests currently fail in bleadperl on Win32 with the
>
> :stdio layer:
>
[snip]
> and then hangs.  If I kill the most "junior" perl.exe process in the
> process tree at this point then the remainder of the test continues.

[snip]

> This problem has been causing my overnight Smokes to hang ever since I
> switched from perl-5.8.x to perl-current, so I don't know when this
> problem first arose.

It has been there for quite a while with MinGW2 in both 5.8.1 and 5.9.0 (which 
is why I stopped smoking win32 regularly)

Looking at the smoke-reports from my windows machine I'd say somewhere 
between:

	http://nntp.x.perl.org/group/perl.daily-build.reports/4334
and
	http://nntp.x.perl.org/group/perl.daily-build.reports/4717

(I might have missed something in the archives)

> The test runs fine if I "set PERLIO=:perlio :crlf" instead, and of
> course it worked under 5.8.1 with both :stdio and :perlio.
>
> - Steve

Good luck,

Abe
-- 
Let's not cloud the issue with facts, shall we?
                                   -- Jarkko Hietaniemi on p5p @ 2003-05-02


Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About