develooper Front page | perl.perl5.porters | Postings from August 2003

Re: need your help to test mod_perl with perl-5.8.1-RC3

Thread Previous | Thread Next
From:
Michael G Schwern
Date:
August 1, 2003 03:14
Subject:
Re: need your help to test mod_perl with perl-5.8.1-RC3
Message ID:
20030801101352.GB14328@windhund.schwern.org
On Fri, Aug 01, 2003 at 10:03:20AM +0100, Steve Hay wrote:
> >This bug evidently goes back a long way:  MM 6.06_02 fails in the same 
> >way as 6.13.
> >
> >I tried to use MM 6.06_01, but it wouldn't build itself ("don't know 
> >how to make 'C:\perl5\libNAME'").  Instead, I knife-and-forked it into 
> >place, but when I tried to use it to build libapreq, I just got the 
> >same error again - "don't know how to make 'C:\perl5\libNAME'". 
> 
> OK, I've got MM 6.06_01 building now (it was generating broken Makefiles 
> -- needed to change DIRFILESEP from \ to ^\, and fill in the missing 
> *PERLSAFE macros), and the bad news is that it doesn't build 
> libapreq-1.2 either!  I still get the "unresolved external symbol 
> boot_libapreq" error.
> 
> So it's one of the many changes between 6.05 and 6.06_01 that broke it.

Well, that narrows it down quite a bit.

Which version of mod_perl and Apache is this against and *exactly* what do
I have to do to exercise this bug?  I haven't built mod_perl in a long time.


-- 
I'll tell you what beats voodoo every time, a big ass knife.
	-- "Overkill" Battlebot driver

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About