develooper Front page | perl.perl5.porters | Postings from May 2003

Re: Time::Local on CPAN?

Thread Previous | Thread Next
From:
Alan Burlison
Date:
May 31, 2003 13:28
Subject:
Re: Time::Local on CPAN?
Message ID:
3ED91040.2060802@sun.com
Rafael Garcia-Suarez wrote:

> By the way :
> 
> Did you know that some OS vendors still ship their latest supported versions
> with much older perls ?
> For example, SCO Open UNIX 8 comes with perl 5.004.

This isn't always quite as stick in the mud as it at first seems - for 
example Solaris 9 ships with 5.005_03 (for backwards compatibility with 
Solaris 8) *and* 5.6.1 + patches.  At the time this was integrated into 
Solaris 9, it was in fact *ahead* of the then-current 5.6.1.  Don't forget 
OS release cycles are often longer and/or out of step with the perl release 
cycles.

I'm hoping to ship perl 5.8.1 with Solaris 10 (pumpking permitting, of 
course ;-), but by the time Solaris 11 ships, even that will be out of date.

But as we are always told by the Opensource Thought Police, if you have the 
source you can compile your own version, right?  ;-) ;-) ;-)

-- 
Alan Burlison
--


Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About