develooper Front page | perl.perl5.porters | Postings from April 2003

Re: ExtUtils::MakeMaker broken?

Thread Previous
From:
Michael G Schwern
Date:
April 3, 2003 05:54
Subject:
Re: ExtUtils::MakeMaker broken?
Message ID:
20030403083755.GI1107@windhund.schwern.org
On Tue, Feb 18, 2003 at 07:34:16PM +0000, Alan Burlison wrote:
> I have some perl modules that build fine with the ExtUtils::MakeMaker that 
> shipped with 5.6.1, but they generate errors with the latest incarnation:
> 
> $ perl Makefile.PL
> Checking if your kit is complete...
> Looks good
> Subroutine postamble redefined at ./Makefile.PL line 90.
> Writing Makefile for Sun::Solaris::Exacct::Catalog
> Subroutine postamble redefined at ./Makefile.PL line 90.
> Writing Makefile for Sun::Solaris::Exacct::File
> Subroutine postamble redefined at ./Makefile.PL line 94.
> Writing Makefile for Sun::Solaris::Exacct::Object
> Writing Makefile for Sun::Solaris::Exacct
> 
> Each of the sub-Makefile.PL's (e.g. Catalog/Makefile.PL) redefines 
> MY::preamble, which as far as I know is perfectly valid thing to do.  In 
> that case, why the warnings?  As I said, this works fine with the 
> ExtUtils::MakeMaker shipped with perl 5.6.1, it is just the latest CPAN 
> version that barfs.  I haven't narrowed down exactly which version this 
> first appeared in, as I'm not sure if it is my fault or MakeMakers fault.

I can't replicate this problem with the version of Sun::Solaris::Exacct
on CPAN and the latest MakeMaker alpha, so I guess it was fixed...


-- 
Remember, any tool can be the right tool.
    -- Red Green

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About