develooper Front page | perl.perl5.porters | Postings from March 2003

PREREQ_PM => { warnings => 0 }

Thread Next
From:
Nicholas Clark
Date:
March 25, 2003 14:38
Subject:
PREREQ_PM => { warnings => 0 }
Message ID:
20030325223440.GC284@Bagpuss.unfortu.net
Following a thread on the london.pm list:

On Wed, Mar 19, 2003 at 10:54:28AM +0000, Simon Wistow wrote:
> Could somebody release warnings to CPAN as a standalone (even if it was
> effectively a no-op if v < 5.6) and then people could remove the require
> perl.5.6.0 from their code?

I think that this idea is worthy of discussion. What would be wrong with
releasing a dummy warnings module to CPAN, so that putting use warnings;
in a module doesn't also mandate require 5.006; ?

People like use warnings; but often it's about the only think that forces
the minimum perl version required up to 5.6. If this could be made to work
then people can have their cake and eat it.

I think I can see one problem - warnings.pm in 5.6.0 has no $VERSION
But is that a fatal flaw?

Nicholas Clark

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About