develooper Front page | perl.perl5.porters | Postings from January 2003

Re: [perl #20536] use if 1, open => ':utf8' fails

Thread Previous
From:
Benjamin Goldberg
Date:
January 27, 2003 11:52
Subject:
Re: [perl #20536] use if 1, open => ':utf8' fails
Message ID:
3E359081.62CF480F@earthlink.net
Autrijus Tang (via RT) wrote:
[snip]
> +  $f =~ s!::!/!g;
> +  eval "require '$f.pm'" or die;       # Adds .pm etc if needed

I'm not sure how important a change it would be, but you might want to
change that from:
   eval "require '$f.pm'" or die;
to:
   require "$f.pm" or die;
Since, afaiks, there's no need for the eval EXPR there anymore.


-- 
$..='(?:(?{local$^C=$^C|'.(1<<$_).'})|)'for+a..4;
$..='(?{print+substr"\n !,$^C,1 if $^C<26})(?!)';
$.=~s'!'haktrsreltanPJ,r  coeueh"';BEGIN{${"\cH"}
|=(1<<21)}""=~$.;qw(Just another Perl hacker,\n);

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About