develooper Front page | perl.perl5.porters | Postings from December 2001

[ID 20011231.001] bug in perl 5.6.3 ?

Thread Next
From:
Maciejewski, Thomas
Date:
December 31, 2001 06:34
Subject:
[ID 20011231.001] bug in perl 5.6.3 ?
Message ID:
7723AD8015FDD411B13F00508BE31C1406C742B5@exnyc01.lehman.com
I am having an issue when spawning a child 

it appears that the environment variable is not being passed to the child
process here is the code:

        my $kidpid = open($fh, "-|");
        if (! $kidpid) {
                open(STDERR, "> /dev/null"); # rlog may complain; ignore.
                exec("rlog","-r", @files);
        }

if I hard code the path to rlog everything works fine ... 
also I printed out the path and it seems that the parent has the correct
path to rlog
any ideas?

I think the environment variables are not getting passed on to the child
processes ... could this be a bug in perl?


------------------------------------------------------------------------------
This message is intended only for the personal and confidential use of the designated recipient(s) named above.  If you are not the intended recipient of this message you are hereby notified that any review, dissemination, distribution or copying of this message is strictly prohibited.  This communication is for information purposes only and should not be regarded as an offer to sell or as a solicitation of an offer to buy any financial product, an official confirmation of any transaction, or as an official statement of Lehman Brothers.  Email transmission cannot be guaranteed to be secure or error-free.  Therefore, we do not represent that this information is complete or accurate and it should not be relied upon as such.  All information is subject to change without notice.


Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About