develooper Front page | perl.perl5.porters | Postings from November 2001

Re: Extra MakeMaker noise in lib/ExtUtils/Embed.t @12791

Thread Previous | Thread Next
From:
Nick Ing-Simmons
Date:
November 1, 2001 04:03
Subject:
Re: Extra MakeMaker noise in lib/ExtUtils/Embed.t @12791
Message ID:
20011101120033.6376.4@bactrian.elixent.com
Andy Dougherty <doughera@lafayette.edu> writes:
>I saw this crawl by today whilst waiting for the tests to finish, and I'm
>not sure what to make of it.
>
>.../lib/ExtUtils/Embed....Note (probably harmless): No library found for -lperl
>ok
>
>If I'm trying to embed perl, being unable to find -lperl may well not be
>harmless :-)  On the other hand, since I haven't installed perl yet,
>I wouldn't expect MakeMaker to find -lperl in my installation
>directory.  Still, the test managed to finish 'ok' somehow.

Because Embed.t supplies the part to -lperl itself.

>
>At a minimum, that noise shouldn't show up in the test output.  At a
>deeper level, I'd appreciate someone more familiar with the test verifying
>that the test is truly testing what it thinks it's testing. (e.g. why is
>it looking for -lperl if it isn't going to use it, for example.)

It is going to use it. But ExtUtils::* fails to find it despite being given
an @INC suitable for a non-installed perl. The snag is that relative path
is not same for installed vs uninstalled.

I agree noise should be silenced.


--
Nick Ing-Simmons
http://www.ni-s.u-net.com/



Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About