develooper Front page | perl.perl5.porters | Postings from August 2001

Re: [PATCH 2 of 3] $] is deprecated - EXTERMINATE, EXTERMINATE, EXTERMINATE

Thread Previous | Thread Next
From:
Rafael Garcia-Suarez
Date:
August 23, 2001 09:11
Subject:
Re: [PATCH 2 of 3] $] is deprecated - EXTERMINATE, EXTERMINATE, EXTERMINATE
Message ID:
20010823181707.A28937@rafael
John Peacock wrote:
> 
> If it is used as a version string, it will be upgraded to be a version
> string (if the tokenizer didn't already catch it).  So
> 
> 	$VERSION = "5.6.1";  
> and	$VERSION = 5.6.1;
> 
> would both be compared as "\5\6\1" automagically.

How would you achieve this ?
And this seems a little bit too DWIMmy: I expect "5.6.1" to be
equivalent to v53.46.54.46.49. At least on ASCII machines.

-- 
Rafael Garcia-Suarez

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About