develooper Front page | perl.perl5.porters | Postings from August 2001

Re: bleadperl on fire, Win95+4NT

Thread Previous | Thread Next
From:
Nikola Knezevic
Date:
August 18, 2001 01:57
Subject:
Re: bleadperl on fire, Win95+4NT
Message ID:
60380251.20010818105616@tesla.rcub.bg.ac.yu
Michael> Smoke reported forwarded on from smokers@perl.org.  Looks like a hot
Michael> time in Win32 tonite.
Michael> F F F F USE_PERLCRT=undef USE_MULTI=define USE_ITHREADS=define USE_IMP_SYS=define
Michael> F F F F USE_PERLCRT=define USE_MULTI=define USE_ITHREADS=define USE_IMP_SYS=define
Michael> | | | +- PERLIO = perlio CFG=DEBUG
Michael> | | +--- PERLIO = stdio  CFG=DEBUG
Michael> | +----- PERLIO = perlio
Michael> +------- PERLIO = stdio

Here is what I've said to Michael in <smokers@perl.org>:

Well, some failures are due to hardcoded values in tests. Other are
just,
 well, broken.
Interesting bit is io/fs.t test, which fails on perl 5.005_03,
ActivePerl 522 and in every bleadperl so far. There might be something
wrong with OS.
For other tests, I'll check them right now.

And op\magic... Well there is something strange in it.
When I first time patched it (for 4NT) compatability (with regex
/foo$/)
everything worked OK. But, with Jarkko's /^(__NoNeSuCh=)foo$/ it failed
again. Then, when I've added /^(?: part, it worked OK. Gremlins, I tell
you...

Also, In some tests I've noticed output from harness, like this:
FAILED blah,blah
expected:
xxx
yyy
something
GOT:
xxx
yyy
something

And that's strange too.

If someone needs extended reports, just let me know.


-- 

Nikola Knezevic [indy@hemo.net] [ http://users.hemo.net/indy ]


Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About