develooper Front page | perl.perl5.porters | Postings from March 2001

Re: building bleadperl failed on cygwin

Thread Previous
From:
Gerrit P. Haase
Date:
March 10, 2001 14:44
Subject:
Re: building bleadperl failed on cygwin
Message ID:
3AAABCFD.3475.B15C68C@localhost
<Am 2001-03-10 4:24 wars, als Gerrit P. Haase schrieb:>
< building bleadperl failed on cygwin >

> At first, it seems to me, that i need perl installed to build perl,
> before perl.exe is build, it is called to execute embed.pl and warnings.pl?

The first lines of make:

make: Entering directory `/src/buildperl'
GNUmakefile:250: warning: overriding commands for target `perlmain.o'
GNUmakefile:192: warning: ignoring old commands for target `perlmain.o'
perl embed.pl
perl warnings.pl
`sh  cflags libperl5_7_0 miniperlmain.o`  miniperlmain.c
	  CCCMD =  gcc -DPERL_CORE -c -DPERL_USE_SAFE_PUTENV -fno-strict-

> The second is, that i got problems with perlio.c.
> Don't know, whether the stackdumps result of this, but it seems to.

The stackdumps are gone, my linker was broken.
 
> siebenschlaefer@LORELEY /src
> $ uname -s -r
> CYGWIN_NT-4.0 1.1.8(0.34/3/2)
> =================================
> patchlevel is 9092
> 
> ==================snip=======================================================
> perlio.c: In function `perlsio_binmode':
> perlio.c:73: warning: passing arg 1 of `PerlIO_fileno' from incompatible pointer type
[...]

But i got this "warning" again today...

Ciao,

Gerrit

-- 
# perl is so cool.
Gerald Oskoboiny, validator source

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About