develooper Front page | perl.perl5.porters | Postings from February 2001

Re: [AIX] [gsar@ActiveState.com: v5.6.1 trial2 is available]

Thread Previous | Thread Next
From:
Ciaran.Deignan
Date:
February 23, 2001 14:52
Subject:
Re: [AIX] [gsar@ActiveState.com: v5.6.1 trial2 is available]
Message ID:
Pine.A41.4.33.0102231156340.144270-100000@isabelle.frec.bull.fr
On Wed, 21 Feb 2001, Jens-Uwe Mager wrote:

Hi Jum ;-),

> to import symbols from the main program. The patch already does that in
> makedef.pl for the perl.exp file, but only on AIX 4.3 and above because
> the older AIX linkers do strange things if this option is used.

I tried your patch on v5.6.1 trial2. It built and the resulting perl
passed all its tests.

However when I try to use this perl to build mod_perl, it doesn't
even succeed in performing the configuration. I use the
following configuration command:

/usr/local/bin/perl5.6.1 Makefile.PL  \
	USE_APXS=1  WITH_APXS=/usr/local/bin/apxs  \
	PERL_USELARGEFILES=0

No error messages are dispayed, the configuration just stops.
When I add a -w to the options I get 2 warnings:


....
PerlSSI.....................disabled (enable with PERL_SSI=1)

Use of uninitialized value in hash element at Makefile.PL line 1654.
Use of uninitialized value in hash element at Makefile.PL line 1654.
Configuring mod_perl for building via APXS
 + Creating a local mod_perl source tree
 + Setting up mod_perl build environment (Makefile)
 + id: mod_perl/1.25
 + id: Perl/v5.6.1 (aix) [/usr/local/bin/perl5.6.1]
Now please type 'make' to build libperl.so
Use of uninitialized value in hash element at Makefile.PL line 1654.
Use of uninitialized value in numeric ge (>=) at Makefile.PL line 1058.
#

but with perl5.6.0 I also get these warnings:

....
PerlSSI.....................disabled (enable with PERL_SSI=1)

Use of uninitialized value in hash element at Makefile.PL line 1654.
Use of uninitialized value in hash element at Makefile.PL line 1654.
Configuring mod_perl for building via APXS
 + Creating a local mod_perl source tree
 + Setting up mod_perl build environment (Makefile)
 + id: mod_perl/1.25
 + id: Perl/v5.6.0 (aix) [/usr/local/bin/perl5.6.0]
Now please type 'make' to build libperl.so
Use of uninitialized value in hash element at Makefile.PL line 1654.
Use of uninitialized value in numeric ge (>=) at Makefile.PL line 1058.
Checking CGI.pm VERSION..........ok
Checking for LWP::UserAgent......ok
.....


Perl5.6.0 completes the configuration normally.

The only thing I can imagine is that the "new" perl is
trying to open modules in the 5.6.0 or 5.5.3 site_perl subdirectories,
and that there is an incompatibility with the link options. But I can't
imagine what that incompatibility is.

Bye
Ciaran


+-------------------------------------------------------------------------+
Ciaran Deignan                                Tel: (France) 04 76 29 79 92
BULL XS-BU (http://www-frec.bull.com)                 HA and Consolidation

Mail to: Ciaran.Deignan@bull.net                        Bullcom: 229 79 92
PGP: B1 78 FB 88 FD 86 58 A8  89 7B 22 8C D0 E8 71 FC       Fax: 229 75 18
+-------------------------------------------------------------------------+


Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About