develooper Front page | perl.perl5.porters | Postings from January 2001

[ID 20010105.017] Can not install perl 5.6.0 on Alpha with UNIX 4.0F.

From:
HARRIPE
Date:
January 5, 2001 11:19
Subject:
[ID 20010105.017] Can not install perl 5.6.0 on Alpha with UNIX 4.0F.
Message ID:
6929E9CCFD1AD011B97500805FEA548D0517EA07@XCGNY004
I am trying to install perl 5.6.0 on a Compaq/Digital Alpha, running Digital
UNIX 4.0. I ran "make distclean" and "rm -f config.sh Policy.sh". At the end
of "sh Configure -de", the script runs "make depend". This starts an
(apparently) infinite loop of:
    sh ./makedepend MAKE=make
    make depend MakeDEPEND=
these two commands repeat 44 times until UNIX returns an error:
    ./makedepend: fork failed - too many processes

"make depend" runs makedepend. makedepend includes the command:
    $MAKE clist || ($echo "Searching for .c files...";    \
        $echo *.c | $tr ' ' $trn | egrep -v '\*' >.clist)
This command apparently causes the recursion; echo lines I added before and
after shows it is called in every recursion, and the following line is never
called.

I get the same result trying to install perl5.005_3.

I have previously installed perl 5.3.x on Digital UNIX, and 5.6.0 on linux,
with no problems. I posted this question on comp.lang.perl.misc; no replies.
I can supply a copy of the installation script and other files if you want.

What is wrong? How do I fix it? How do I install perl 5.6.0 on Digital UNIX
4.0?A

 <<MYCONFIG>> 

Peter Harrington
harripe@mail.northgrum.com

 <<Myconfig.txt>> 



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About