develooper Front page | perl.perl5.porters | Postings from December 2000

[ID 20001226.001] dec_osf.sh mis-parses gcc version 2.95.2 asless than 2.95, causing installation-failure

Thread Next
From:
jhbrown
Date:
December 26, 2000 01:29
Subject:
[ID 20001226.001] dec_osf.sh mis-parses gcc version 2.95.2 asless than 2.95, causing installation-failure
Message ID:
uv6puify1hu.fsf@suspiria.ai.mit.edu
This is a bug report for perl from jhbrown@newspaper-taxi.ai.mit.edu,
generated with the help of perlbug 1.28 running under perl v5.6.0.


-----------------------------------------------------------------
[Please enter your report here]

The configuration hint file perl-5.6.0/hints/dec_osf.sh mis-parses
"gcc version 2.95.2" as being a version less than 2.95, and thus
running
> sh Configure -Dcc=gcc -de
generates a message saying that building perl doesn't work with older
gccs on this platform (DEC Alpha); the configuration process exits
unsuccessfully as a result.

Appended is a simple patch to the offending file which fixes the
problem by allowing it to parse arbitrarily deep sub-numbering schemes
(e.g. 2.95, 2.95.2, 2.95.2.1, etc.)  It also causes the configuration
process, should it decide to reject a future gcc version, to append
the version string info to the emitted warning so that the user can
eyeball-verify that gcc is, in fact, too old.

Finally, just as a point of information: the warning emitted for older
gccs states, in part: "Note that as of gcc 2.95 (19990728) and Perl
5.6.0 (end of March 2000) if the said Perl is compiled with the said
gcc the lib/sdbm test will dump core."  With gcc 2.95.2 under Digital
UNIX 4.0D, the lib/sdbm test worked just fine.

------------------------------------------------------------------------------

*** dec_osf.sh~	Wed Mar 22 08:51:18 2000
--- dec_osf.sh	Tue Dec 26 02:47:20 2000
***************
*** 65,71 ****
  	# reset
  	_DEC_cc_style=
  case "`$cc -v 2>&1 | grep cc`" in
! *gcc*)	_gcc_version=`$cc -v 2>&1 | grep "gcc version" | sed 's%^gcc version \([0-9]*\)\.\([0-9]*\) .*%\1 \2%'`
  	set $_gcc_version
  	if test "$1" -lt 2 -o \( "$1" -eq 2 -a "$2" -lt 95 \); then
  	    cat >&4 <<EOF
--- 65,71 ----
  	# reset
  	_DEC_cc_style=
  case "`$cc -v 2>&1 | grep cc`" in
! *gcc*)	_gcc_version=`$cc -v 2>&1 | grep "gcc version" | sed 's%^gcc version \([0-9]*\)\.\([0-9]*\)\(\.[0-9]*\)* .*%\1 \2%'`
  	set $_gcc_version
  	if test "$1" -lt 2 -o \( "$1" -eq 2 -a "$2" -lt 95 \); then
  	    cat >&4 <<EOF
***************
*** 87,92 ****
--- 87,93 ----
  Cannot continue, aborting.
  
  EOF
+ 	    echo $_gcc_version >& 4
  	    exit 1
  	fi
          ;;

------------------------------------------------------------------------------




[Please do not change anything below this line]
-----------------------------------------------------------------
---
Flags:
    category=install
    severity=medium
---
Site configuration information for perl v5.6.0:

Configured by jhbrown at Tue Dec 26 02:47:30 EST 2000.

Summary of my perl5 (revision 5.0 version 6 subversion 0) configuration:
  Platform:
    osname=dec_osf, osvers=4.0, archname=alpha-dec_osf
    uname='osf1 newspaper-taxi.ai.mit.edu v4.0 878 alpha '
    config_args='-Dcc=gcc -de'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
    useperlio=undef d_sfio=undef uselargefiles=define 
    use64bitint=define use64bitall=define uselongdouble=undef usesocks=undef
  Compiler:
    cc='gcc', optimize='-O3', gccversion=2.95.2 19991024 (release)
    cppflags='-ansi -fno-strict-aliasing -I/usr/local/include -DLANGUAGE_C'
    ccflags ='-ansi -fno-strict-aliasing -I/usr/local/include -DLANGUAGE_C'
    stdchar='unsigned char', d_stdstdio=define, usevfork=false
    intsize=4, longsize=8, ptrsize=8, doublesize=8
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=8
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, usemymalloc=y, prototype=define
  Linker and Libraries:
    ld='ld', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /usr/shlib /usr/ccs/lib /usr/lib/cmplrs/cc /usr/lib /var/shlib
    libs=-ldbm -ldb -lm -liconv
    libc=/usr/shlib/libc.so, so=so, useshrplib=false, libperl=libperl.a
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '
    cccdlflags='-fpic', lddlflags='-shared -expect_unresolved "*" -msym -std -s -L/usr/local/lib'

Locally applied patches:
    

---
@INC for perl v5.6.0:
    /usr/local/lib/perl5/5.6.0/alpha-dec_osf
    /usr/local/lib/perl5/5.6.0
    /usr/local/lib/perl5/site_perl/5.6.0/alpha-dec_osf
    /usr/local/lib/perl5/site_perl/5.6.0
    /usr/local/lib/perl5/site_perl
    .

---
Environment for perl v5.6.0:
    HOME=/homestuff/jhbrown
    LANG (unset)
    LANGUAGE (unset)
    LD_LIBRARY_PATH (unset)
    LOGDIR (unset)
    PATH=/usr/sbin:/usr/local/bin:/com/tetex/bin/alpha-osf4.0/:/usr/opt/java118/bin:/usr/bin/X11:/usr/kerberos/bin:/usr/local/afsws:/usr/etc:/usr/local/bin:/usr/local/X11:/usr/bin:/bin:/usr/ucb:/sbin:/usr/sbin:/usr/bin/mtools
    PERL_BADLANG (unset)
    SHELL=/usr/local/bin/tcsh


Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About