develooper Front page | perl.perl5.porters | Postings from March 2000

[ID 20000316.003] Help needed!Regarding error in DBI.pm

From:
revathi chander
Date:
March 16, 2000 03:18
Subject:
[ID 20000316.003] Help needed!Regarding error in DBI.pm
Message ID:
20000316111709.4751.qmail@nwcst267.netaddress.usa.net

  I used the statement use DBI in the perl prg.

  This perl was automatically loaded when Redhat5.2 was installed.

  The prog statement

#!/usr/local/bin/perl

use DBI;
exit;
#End of testing module

Interpreter tells that 

  can't locate DBI.pm in @INC (@INC contains:
/usr/lib/perl5/i386-linux/5.00404    /usr/lib/perl5
/usr/lib/perl5/site_perl/i385-linux
/usr/lib/perl5/site_perl
At test.pl

   As I use Pgsql as the backend 
I installed perl-PgSQL-0_51-1_i386.rpm(downloaded from rpmfind.net)

   It provided the required files in the paths mentioned.

   Still it says the same error.(In the command prompt).

   But one file named as test1.pl automatically while installing ther
above rpm file.

   #perl test1.pl

   says that 

      Unable to locate unix.pm.and same as the above error.

      downloaded perl-5_004m7-1_i386.rpm(from rpmfind.net)

       Tried to install.It says that
  
         Unable to install.

         Can u help me please?I'm in urgency.

thanks,
Revathi.   
    

____________________________________________________________________
Get free email and a permanent address at http://www.netaddress.com/?N=1



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About