develooper Front page | perl.perl5.changes | Postings from March 2021

[Perl/perl5] e3a57d: use PERL_VERSION_LE not 5.33+ PERL_VERSION_LT

From:
mohawk2 via perl5-changes
Date:
March 24, 2021 12:42
Subject:
[Perl/perl5] e3a57d: use PERL_VERSION_LE not 5.33+ PERL_VERSION_LT
Message ID:
Perl/perl5/push/refs/heads/blead/3e25f6-f1f3e1@github.com
  Branch: refs/heads/blead
  Home:   https://github.com/Perl/perl5
  Commit: e3a57d70d0b8c89c2c37833064dd4e2ecc302b58
      https://github.com/Perl/perl5/commit/e3a57d70d0b8c89c2c37833064dd4e2ecc302b58
  Author: Ed J <mohawk2@users.noreply.github.com>
  Date:   2021-03-24 (Wed, 24 Mar 2021)

  Changed paths:
    M dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm

  Log Message:
  -----------
  use PERL_VERSION_LE not 5.33+ PERL_VERSION_LT

As ExtUtils::ParseXS is dual-life it needs to use stable Perl macros.


  Commit: f1f3e1235de245a2fc5947224992ed28b9e75f99
      https://github.com/Perl/perl5/commit/f1f3e1235de245a2fc5947224992ed28b9e75f99
  Author: Ed J <mohawk2@users.noreply.github.com>
  Date:   2021-03-24 (Wed, 24 Mar 2021)

  Changed paths:
    M MANIFEST
    M dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm
    M dist/ExtUtils-ParseXS/t/001-basic.t
    A dist/ExtUtils-ParseXS/t/XSBroken.xs

  Log Message:
  -----------
  ExtUtils::ParseXS fix error-message bug


Compare: https://github.com/Perl/perl5/compare/3e25f6d2dce9...f1f3e1235de2



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About