develooper Front page | perl.perl5.changes | Postings from January 2019

[perl.git] branch smoke-me/jkeenan/133776-carp-uninit-value-warningupdated. v5.29.7-15-gf7528e16d0

From:
James Keenan
Date:
January 21, 2019 20:43
Subject:
[perl.git] branch smoke-me/jkeenan/133776-carp-uninit-value-warningupdated. v5.29.7-15-gf7528e16d0
Message ID:
E1glgPo-0006lj-Hb@git.dc.perl.space
In perl.git, the branch smoke-me/jkeenan/133776-carp-uninit-value-warning has been updated

<https://perl5.git.perl.org/perl.git/commitdiff/f7528e16d0b40d2dce8c7731d11d11fa35461088?hp=9dd1a314a9372ebcf83e2eb8226367ed1ed4b6f8>

  discards  9dd1a314a9372ebcf83e2eb8226367ed1ed4b6f8 (commit)
- Log -----------------------------------------------------------------
commit f7528e16d0b40d2dce8c7731d11d11fa35461088
Author: James E Keenan <jkeenan@cpan.org>
Date:   Mon Jan 21 14:20:40 2019 -0500

    NOT READY FOR MERGING (see below).
    
    Keep porting tests happy.  Carp and Carp::Heavy must have same $VERSION.
    
    The significant changes to Carp.pm in this branch are having the effect
    of new warnings being generated during dist/Carp/t/stash_deletion.t.
    This needs investigation.

-----------------------------------------------------------------------

Summary of changes:
 dist/Carp/lib/Carp/Heavy.pm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/dist/Carp/lib/Carp/Heavy.pm b/dist/Carp/lib/Carp/Heavy.pm
index a9b803c76a..028d2a206e 100644
--- a/dist/Carp/lib/Carp/Heavy.pm
+++ b/dist/Carp/lib/Carp/Heavy.pm
@@ -2,7 +2,7 @@ package Carp::Heavy;
 
 use Carp ();
 
-our $VERSION = '1.50';
+our $VERSION = '1.51';
 $VERSION =~ tr/_//d;
 
 # Carp::Heavy was merged into Carp in version 1.12.  Any mismatched versions

-- 
Perl5 Master Repository



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About