develooper Front page | perl.perl5.changes | Postings from March 2018

[perl.git] branch blead updated. v5.27.9-103-gf68b759104

From:
Father Chrysostomos
Date:
March 5, 2018 16:47
Subject:
[perl.git] branch blead updated. v5.27.9-103-gf68b759104
Message ID:
E1estGP-0001gw-6A@git.dc.perl.space
In perl.git, the branch blead has been updated

<https://perl5.git.perl.org/perl.git/commitdiff/f68b759104a3343a4765dcab96e5e5b04e799f25?hp=8e4ae0ffc862568e59935c22e552488892eabe59>

- Log -----------------------------------------------------------------
commit f68b759104a3343a4765dcab96e5e5b04e799f25
Author: Father Chrysostomos <sprout@cpan.org>
Date:   Mon Mar 5 08:46:41 2018 -0800

    Increase ExtUtils::ParseXS(::*) version to 3.39

commit 559c9ec2c0df2ca09de621378c4f8a7d49258f02
Author: Father Chrysostomos <sprout@cpan.org>
Date:   Mon Mar 5 08:39:36 2018 -0800

    Add Shoichi Kaji to AUTHORS

commit 8a891375b36abae2efae1301601032d4f062b903
Author: Shoichi Kaji <skaji@cpan.org>
Date:   Mon Mar 5 23:25:49 2018 +0900

    RT #132935: correctly check VERSIONs in ExtUtils::ParseXS
    
    The following version check does not work correctly:
    
    BEGIN { $VERSION = '3.38' }
    use ExtUtils::ParseXS::Constants $VERSION;
    
    The reason is that we must use version "literals",
    not "variables" in `use Module VERSION`.
    For the sake of ease of maintenance,
    we use "require" and "->VERSION", instead of "use" here.

commit 0c5a5b273a4ce037b635202dcefda1522fb4bb9f
Author: Father Chrysostomos <sprout@cpan.org>
Date:   Sun Mar 4 22:05:46 2018 -0800

    perldiag typo

-----------------------------------------------------------------------

Summary of changes:
 AUTHORS                                                  |  1 +
 dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm            | 10 +++++-----
 dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Constants.pm  |  2 +-
 dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/CountLines.pm |  2 +-
 dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Eval.pm       |  2 +-
 dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Utilities.pm  |  2 +-
 pod/perldiag.pod                                         |  2 +-
 7 files changed, 11 insertions(+), 10 deletions(-)

diff --git a/AUTHORS b/AUTHORS
index 3fc48c7c30..f97682f615 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -1127,6 +1127,7 @@ Shinya Hayakawa			<hayakawa@livedoor.jp>
 Shirakata Kentaro		<argrath@ub32.org>
 Shishir Gundavaram		<shishir@ruby.ora.com>
 Shlomi Fish			<shlomif@cpan.org>
+Shoichi Kaji			<skaji@cpan.org>
 Simon Cozens			<simon@netthink.co.uk>
 Simon Glover			<scog@roe.ac.uk>
 Simon Leinen
diff --git a/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm b/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm
index 16359ccbce..e1f0940745 100644
--- a/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm
+++ b/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS.pm
@@ -11,12 +11,12 @@ use Symbol;
 
 our $VERSION;
 BEGIN {
-  $VERSION = '3.38';
+  $VERSION = '3.39';
+  require ExtUtils::ParseXS::Constants; ExtUtils::ParseXS::Constants->VERSION($VERSION);
+  require ExtUtils::ParseXS::CountLines; ExtUtils::ParseXS::CountLines->VERSION($VERSION);
+  require ExtUtils::ParseXS::Utilities; ExtUtils::ParseXS::Utilities->VERSION($VERSION);
+  require ExtUtils::ParseXS::Eval; ExtUtils::ParseXS::Eval->VERSION($VERSION);
 }
-use ExtUtils::ParseXS::Constants $VERSION;
-use ExtUtils::ParseXS::CountLines $VERSION;
-use ExtUtils::ParseXS::Utilities $VERSION;
-use ExtUtils::ParseXS::Eval $VERSION;
 $VERSION = eval $VERSION if $VERSION =~ /_/;
 
 use ExtUtils::ParseXS::Utilities qw(
diff --git a/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Constants.pm b/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Constants.pm
index 57d1eca28b..45b567404d 100644
--- a/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Constants.pm
+++ b/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Constants.pm
@@ -3,7 +3,7 @@ use strict;
 use warnings;
 use Symbol;
 
-our $VERSION = '3.38';
+our $VERSION = '3.39';
 
 =head1 NAME
 
diff --git a/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/CountLines.pm b/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/CountLines.pm
index fe214702b8..5b48449dbb 100644
--- a/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/CountLines.pm
+++ b/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/CountLines.pm
@@ -1,7 +1,7 @@
 package ExtUtils::ParseXS::CountLines;
 use strict;
 
-our $VERSION = '3.38';
+our $VERSION = '3.39';
 
 our $SECTION_END_MARKER;
 
diff --git a/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Eval.pm b/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Eval.pm
index 2e5e97bd05..9eba5e5058 100644
--- a/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Eval.pm
+++ b/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Eval.pm
@@ -2,7 +2,7 @@ package ExtUtils::ParseXS::Eval;
 use strict;
 use warnings;
 
-our $VERSION = '3.38';
+our $VERSION = '3.39';
 
 =head1 NAME
 
diff --git a/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Utilities.pm b/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Utilities.pm
index 947abd2ff4..ae25b33b47 100644
--- a/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Utilities.pm
+++ b/dist/ExtUtils-ParseXS/lib/ExtUtils/ParseXS/Utilities.pm
@@ -5,7 +5,7 @@ use Exporter;
 use File::Spec;
 use ExtUtils::ParseXS::Constants ();
 
-our $VERSION = '3.38';
+our $VERSION = '3.39';
 
 our (@ISA, @EXPORT_OK);
 @ISA = qw(Exporter);
diff --git a/pod/perldiag.pod b/pod/perldiag.pod
index 3abc301f7a..124f1fb248 100644
--- a/pod/perldiag.pod
+++ b/pod/perldiag.pod
@@ -314,7 +314,7 @@ the current set of allowed keys of a restricted hash.
 
 (F) You wrote C<bless $foo> with one argument after somehow causing
 the current package to be freed.  Perl cannot figure out what to
-do, so it throws up in hands in despair.
+do, so it throws up its hands in despair.
 
 =item Attempt to bless into a reference
 

-- 
Perl5 Master Repository



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About