develooper Front page | perl.par | Postings from July 2008

Re: PAR::Packer 0.982

Thread Previous | Thread Next
From:
Sisyphus
Date:
July 31, 2008 03:20
Subject:
Re: PAR::Packer 0.982
Message ID:
8E1994370C9A4915A36C754E9465AD76@desktop2

----- Original Message ----- 
From: "Paul Miller" <listmail@voltar-confed.org>
.
.
>  Also, there are quite a few win32 5.8.8 builds.  Are they
> all interchangeable enough that 5.8.8 is 5.8.8?

Yes, I think so. I haven't heard of any instances where a PAR::Packer built 
using (eg) build 822 of ActivePerl (5.8.8) doesn't work on build 821 of 
ActivePerl (also 5.8.8), or somesuch - but I don't know that it can be 
guaranteed that such a situation could not arise. (Build 822 contains 
patches that are not present in the earlier builds of perl 5.8.8, and if one 
of those patches changes the symbols that are exported by perl58.dll, then 
you can strike trouble. I suspect that patches that could change the 
perl58.dll in that way are excluded by ActiveState ... but I don't know for 
sure.)

Afaik, the only time you get problems is if PAR::Packer was built using perl 
5.v.x, and you try to use that binary on perl 5.v.y (where v is 6 or 8, and 
x != y).

Cheers,
Rob 


Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About