develooper Front page | perl.par | Postings from July 2008

Crash during initial run on winXP

From:
Brad Bowman
Date:
July 7, 2008 19:02
Subject:
Crash during initial run on winXP
Message ID:
4872CA86.2080404@bereft.net

Hello,

I'm trying to work out why the first run of our application
crashes on Win XP with a "Send report to Microsoft" dialog,
but runs fine the second time.  I don't have long to write
this message so can supply further details in a follow up (sorry).

Attached is the log from Dr.Watson, the stack dump is:

*----> Stack Back Trace <----*
WARNING: Stack unwind information not available. Following frames may be wrong.
ChildEBP RetAddr  Args to Child
0012fbf0 2808750e 0083413c 00000001 00000000 perl58!perl_clone_using+0x10be
0012fc44 2804d1a1 008326a0 0083413c 00000000 
perl58!Perl_stashpv_hvname_match+0x22bc
0012fd34 28026e41 0083413c 00862e58 00000006 perl58!Perl_sortsv+0x8d3a
0012fdbc 2801c5ec 0083413c 00000002 00862cfc perl58!Perl_call_list+0x35e
0012fe30 28028846 008697dc 0000006d 00865e6c perl58!Perl_newATTRSUB+0x9c8
00000000 00000000 00000000 00000000 00000000 
perl58!Perl_Guse_safe_putenv_ptr+0x6c8


C:\ddict>perl -v

This is perl, v5.8.8 built for MSWin32-x86-multi-thread
(with 25 registered patches, see perl -V for more detail)

Copyright 1987-2006, Larry Wall

Binary build 817 [257965] provided by ActiveState http://www.ActiveState.com
Built Mar 20 2006 17:54:25

C:\ddict>pp --version
PAR Packager, version 0.970 (PAR version 0.976)
Copyright 2002, 2003, 2004, 2005, 2006 by Audrey Tang <autrijus@autrijus.org>


We use a recent Class::DBI which uses the Clone module, although I think
that different to the interpreter cloning above.

We fork and system in our application, this has caused no end of pain,
and it likely to be involved in this problem.

We use -c bin/par_wrap.pl to dispatch to other bundled utilities.
I don't think this is relevant, it's a modification of what already
happens (or happened when I stole it), but I figure I should come
clean up front.

This has only started to happen recently, I can probably do some
archeology to find out what we changed.

I'll probably try upgrading components next and will post the results.

Has this been encountered before?  Is it fixed somewhere?
Is it just a perl on windows bug tickled by par?

Thanks

Brad

-- 
   Wrap your intentions in needles of pine.                -- Hagakure



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About