develooper Front page | perl.par | Postings from June 2008

Can't locate Image/ExifTool/Writer.pl in @INC

Thread Next
From:
luca bianconi
Date:
June 5, 2008 09:24
Subject:
Can't locate Image/ExifTool/Writer.pl in @INC
Message ID:
8f2e7d910806050923v3aa37f6cl1b405a8595c1eee3@mail.gmail.com
Dear All,

I've just begun trying PAR. I've had no problem in packaging another
application I've written with not a lot of libraries used.
This new one gives me some problems, apparently because it can't find a
library-module in the @INC .

The source code works alright, launching it as executable in perl
interpreter mode.
The packaging ends without any problem. I've looked with the verbose option
selected and apparently there's no error signaled.
The problem just comes when I try to execute one of the function of the
program. It has sense, of course, because the error is related to one of the
routines used in that part of the code.

This is the problem:

*luca@PcLuca:~/compiling/Image/Nine$ ./archivio2
Tk::Error: Error while attempting to call Image::ExifTool::SetNewValue
Can't locate Image/ExifTool/Writer.pl in @INC (@INC contains:
/tmp/par-luca/cache-01188db09d161d9564da7f367963e579c14c925f/inc/lib
/tmp/par-luca/cache-01188db09d161d9564da7f367963e579c14c925f/inc
CODE(0x82d53c4) CODE(0x82d55b0) /usr/local/share/perl/5.8.8/Image/ExifTool)
at (eval 380) line 1.
*

Of course I've tried to include *Image::ExifTool::SetNewValue,* but
apparentl*y* it's not found by tkpp. It makes me think I'm going on not
including the module I should need.*

*I'd be grateful for any suggestion*, *probably I'm wrong on how including
the module.

Thanks in advance,
Luca*
*

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About