develooper Front page | perl.modules | Postings from March 2018

Request for a co-maint on Crypt-OpenSSL-RSA

From:
Sergey Aleynikov
Date:
March 1, 2018 14:20
Subject:
Request for a co-maint on Crypt-OpenSSL-RSA
Message ID:
CAKNj8S1=zF1vnH1XOF1+n3iiVGFjahOi-1BNejNNij0FXo195g@mail.gmail.com
Dear PAUSE admins,

Some time ago, OpenSSL has released it's 1.1.0 version. Which broke
software. A lot of software. It took some time to adopt, but finally
it was released in all major distros. By that time, they had prepared
patches for all perl modules they bundle, including
Crypt::OpenSSL::RSA.

https://rt.cpan.org/Ticket/Display.html?id=117481 - this bug is more
than a year old on rt. We use this module at $work, so we had to
deploy this manually patched version. At that time, I've tried to
contact author through github, by providing a pull request ready to be
merged - https://github.com/monken/Crypt-OpenSSL-RSA/pull/18.

Since no-one replied to those reports, a month ago I've sent a mail
request (plus a notice in the rt queue) to all listed module's
maintainers (iroberts+perl@red-bean.com, onken@netcubed.de,
toddr@cpan.org) describing this situation and asking to either release
an updated version or give me a co-maint, and got no reply.

So now, as a last resort, I'm asking you to give me a co-maint
permission on this module, so I can continue releases for it. My PAUSE
id is RANDIR.

PS: I'm sorry if this appears as a duplicate on the list, but my first
mail hasn't appeared though a week has passed. I also heard that
including a word perl in the message text may help.

Best regards,
Sergey Aleynikov



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About