develooper Front page | perl.module.build | Postings from September 2011

Re: Needing some help with Module::Build and the Intel compiler.

Thread Previous
From:
Steve Mayer
Date:
September 30, 2011 02:17
Subject:
Re: Needing some help with Module::Build and the Intel compiler.
Message ID:
D29AA3A6-54A3-4CB7-9ABD-C45236C59860@me.com
Leon,

  Thanks for the response.  I've tried setting various compatibility modes to no avail.  What I haven't tried is forcing VC 6 compatibility yet.  Maybe I'll give that a shot.

Thanks,

Steve Mayer
smayer69@me.com

"I like rice. Rice is great if you're hungry and want 2000 of something." -- Mitch Hedberg

On Sep 29, 2011, at 3:12 AM, Leon Timmermans wrote:

> On Thu, Sep 29, 2011 at 6:49 AM, Steve Mayer <smayer69@me.com> wrote:
>> Hello,
>> 
>>  I'm attempting to perform a Perl build on Windows 2003 64-bit using the Intel compiler (version 10.1.032) and I'm seeing issues with those modules that are using Module::Build.  Basically when I attempt to build any of these Module::Build based modules, I'm seeing the following type of error:
>> 
>>        perl Build.PL
>>        compilet-qQxoU.
>>       (0): internal error: backend signals
>> 
>> Has anyone seen this type of issue or has more experience with using the Intel compiler (along with VS 2005) to build Perl with?
> 
> Module::Build is using ExtUtils::CBuilder to do compiling and linking.
> AFAIK that doesn't have explicit support for the Intel compiler on
> Windows (though I remember icc having a gcc compatibility mode, maybe
> it works through that). ExtUtils;:CBuilder is a bit of a mess on
> Windows anyway.
> 
> Leon


Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About