develooper Front page | perl.module.build | Postings from April 2007

fforce install Module::Build? and bad version for Module::Build::Version

Thread Next
From:
Jeff Chimene
Date:
April 23, 2007 10:46
Subject:
fforce install Module::Build? and bad version for Module::Build::Version
Message ID:
462CD08D.3010505@gmail.com
Hi:

Installing the current version of DateTime::TimeZone
requires Module::Build.

It looks like I must use "fforce install Module::Build"
to install:

t/moduleinfo..........NOK 79/81
#   Failed test 'version for default package'
#   at t/moduleinfo.t line 422.
#          got: '0.60.128'
#     expected: 'v0.60.128'
t/moduleinfo..........NOK 81/81
#   Failed test 'version for embedded package'
#   at t/moduleinfo.t line 425.
#          got: '0.61.129'
#     expected: 'v0.61.129'
# Looks like you failed 2 tests of 81.
t/moduleinfo..........dubious
        Test returned status 2 (wstat 512, 0x200)

Additionally, this leaves me with a bad version
number for Module::Build::Version:

Module::Build::Version            0      0.58 
KWILLIAMS/Module-Build-0.2807...

Trying "fforce install Module::Build::Version" does not change
the module version. There seems to be no way to update the package
version so that the command "r" (report updates) reports a good
version for this package.

Cheers,
jec


Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About