develooper Front page | perl.module.build | Postings from January 2007

testpodcoverage

Thread Next
From:
Eric Wilhelm
Date:
January 5, 2007 11:25
Subject:
testpodcoverage
Message ID:
200701051125.34899.ewilhelm@cpan.org
This always reports everything in dotReader as "not ok ... counldn't 
find pod".

  $ ./Build testpodcoverage
  1..78
  not ok 1 - Pod coverage on dtRdr
  #   Failed test 'Pod coverage on dtRdr'
  #   ...
  # dtRdr: couldn't find pod
  not ok 2 - Pod coverage on dtRdr::Library
  #   Failed test 'Pod coverage on dtRdr::Library'
  #   ...
  # dtRdr::Library: couldn't find pod
  # ...

But if I add lib to @INC, it works

  $ perl -Ilib ./Build testpodcoverage
  1..78
  ok 1 - Pod coverage on dtRdr
  not ok 2 - Pod coverage on dtRdr::Library
  #   Failed test 'Pod coverage on dtRdr::Library'
  #   ...
  # Coverage for dtRdr::Library is 73.3%, with 4 naked subroutines:
  # ...

What I can't figure out is why it only fails in dotReader, not in 
Module::Build or a few other places that I've tried it.  Is it 
something in my Build.PL or other aspect of the distribution?

Can anyone see what I'm doing wrong, or should we add to @INC in 
ACTION_testpodcoverage?

  http://svn.dotreader.com/svn/dotreader/trunk/
  or from the cpan shell, `look dtRdr`

Thanks,
Eric
-- 
You can't whack a chisel without a big wooden mallet.
---------------------------------------------------
    http://scratchcomputing.com
---------------------------------------------------

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About