develooper Front page | perl.module-authors | Postings from November 2011

New module naming

Thread Previous | Thread Next
From:
Trystan
Date:
November 6, 2011 14:28
Subject:
New module naming
Message ID:
CAARGucxu2oGvS8A3gK99mLojOiz7hk8P4eCfK1nFzTJforhk9w@mail.gmail.com
Hi. I've written few libraries I'd like to release on CPAN and I'm looking
for some advice on how to name them.

I found this idea in Head First OOA&D<http://headfirstlabs.com/books/hfooad/>,
chapter 5. It's somewhat like a very simple version of Key-Value
Coding<http://developer.apple.com/library/mac/#documentation/Cocoa/Conceptual/KeyValueCoding/Articles/Overview.html%23//apple_ref/doc/uid/20001838-SW1>.
It's also very similar to
Object::Generic<http://search.cpan.org/%7Ejmahoney/Object-Generic-0.13/lib/Object/Generic.pm>but
I didn't use AUTOLOAD and I implemented 'equals' and 'contains'
methods
in order to make the objects searchable within a container.

Here's an example:

 my $a = tbd_name::Object->new();
 my $b = tbd_name::Object->new();

 $a->set( "ID", tbd_name::String->new("1234a") );
 $b->set( "ID", tbd_name::String->new("1234a") );

 print $a->get("ID");

 $a->equals($b) ? print "yes";

 $container = tbd_name::List->new();
 $container->add($a);

 $container->search($b);  #which returns $a

What do I call this thing? I'm thinking the namespace would be 'KeyValue::'
or 'KeyVal::' Would that make sense? (That namespace doesn't seem to be
used.) Should this go in 'Class::'?

Thanks.

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About