develooper Front page | perl.libwww | Postings from January 2014

trouble with Crypt::SSLeay install

Thread Next
From:
Joe
Date:
January 22, 2014 17:29
Subject:
trouble with Crypt::SSLeay install
Message ID:
52DF03B7.30209@oddesse.com
Hello -
I'm sorry to bother you but I'm having a ton of trouble trying to 
install Crypt::SSLeay 0.64 into my new system.
http://search.cpan.org/~nanis/Crypt-SSLeay/SSLeay.pm

The server is Ubuntu 12.04 with Perl 5.14; should this work?

This is the install command I'm trying to use to put this into my custom 
location:

  PERL5LIB="/home/joet/bin_joet/perl" make install 
PREFIX=/home/joet/bin_joet INSTALLPRIVLIB="/home/joet/bin_joet/perl" 
INSTALLSITELIB="/home/joet/bin_joet/perl" 
INSTALLARCHLIB="/home/joet/bin_joet/perl" 
INSTALLSITEARCH="/home/joet/bin_joet/perl" 
INSTALLVENDORARCH="/home/joet/bin_joet/perl"

And this is the tail end of the installation showing the failure:

Writing Makefile for Crypt::SSLeay
cp lib/Crypt/SSLeay/X509.pm blib/lib/Crypt/SSLeay/X509.pm
cp lib/Net/SSL.pm blib/lib/Net/SSL.pm
cp SSLeay.pm blib/lib/Crypt/SSLeay.pm
cp lib/Crypt/SSLeay/MainContext.pm blib/lib/Crypt/SSLeay/MainContext.pm
cp lib/Crypt/SSLeay/CTX.pm blib/lib/Crypt/SSLeay/CTX.pm
cp lib/Crypt/SSLeay/Conn.pm blib/lib/Crypt/SSLeay/Conn.pm
cp lib/Crypt/SSLeay/Err.pm blib/lib/Crypt/SSLeay/Err.pm
/usr/bin/perl /home/joet/bin_sugardvd/perl/ExtUtils/xsubpp  -typemap 
/usr/share/perl/5.14/ExtUtils/typemap -typemap typemap  SSLeay.xs > 
SSLeay.xsc && mv SSLeay.xsc SSLeay.c
make: *** No rule to make target `/usr/lib/perl/5.14/CORE/cc_runtime.h', 
needed by `SSLeay.o'.  Stop.


The problem seems to be an incompatibility between Crypt::SSLeay and 
Perl 5.14, since there is no cc_runtime.h, but admittedly I'm a bit 
lost; no one else seems to be reporting the issue.

Can you provide any guidance?
thanks in advance,
Joe



Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About