develooper Front page | perl.libwww | Postings from August 2013

Bug in Digest authentication: Request with digest authenticationfails if nonce is expired / GIT pull request #40

Thread Next
From:
stefan lauterbach
Date:
August 16, 2013 10:20
Subject:
Bug in Digest authentication: Request with digest authenticationfails if nonce is expired / GIT pull request #40
Message ID:
520DFCC7.9070701@pli.de
Hello,

When I used digest authentication in libwww, I came across the issue 
that the nonce expiry is not handled correctly, as described in issue 
#39 on github (by me). I also found an existing bug report on rt, which 
describes the problem even better: 
https://rt.cpan.org/Public/Bug/Display.html?id=75908.

I spent a lot of time to understand the module structure and fixed the 
issue, I also created tests for it (fixing also some other tests that 
were non-operational), and I created pull request #40.

I have not received any response since. As also several other pull 
requests are unanswered, the module looks quite unmaintained.

Please have a look at this, I really do not want to bother anyone, but 
it is a real problem in a subcase of a central perl library, the fix is 
already provided.

I am also ready to give more details and to improve my solution, if you 
find any issues with it. However, I would not like to see my efforts 
wasted. Please advise me how to proceed.

Thank you.



Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About