develooper Front page | perl.libwww | Postings from October 2001

Test errors while installing

From:
Diego de Lima
Date:
October 6, 2001 13:41
Subject:
Test errors while installing
Message ID:
jUsT.aNoTheR.mEsSaGe.iD.100232069514956@www.isla.com.br
I've already spent some time trying to install libwww. I'm getting 
the following when I do 'make test':

------------------------------------
[root@lisa t]# ./TEST -v local/http
local/http..........1..18
Will access HTTP server at http://lisa.sistemica:1037/
Bad request...
not ok 1
not ok 2
Simple echo...
not ok 3
not ok 4
Send file...
not ok 5
not ok 6
not ok 7
Check redirect...
not ok 8
Can't call method "is_redirect" on an undefined value at local/http.
t line 189, <DAEMON> chunk 1.
HTTP Server terminated
dubious
        Test returned status 2 (wstat 512, 0x200)
Constant subroutine __need_size_t undefined at /usr/lib/perl5/5.00503/i386-
linux/stddef.ph line 131.
Undefined subroutine &Test::Harness::WCOREDUMP called at /usr/lib/perl5/5.
00503/Test/Harness.pm line 288.
-----------------------------------------------

I've already read an e-mail from Gisle saying it use to happens when 
LWP doesn't finds the host (in this case, 'lisa.sistemica'). But 
I think this is not the case, as I see the server part of TEST up.
I mean: I CAN telnet it and send requests to it while testing, but 
the TEST itself can't, falling in erros!

I've tryed to ignore this fails and do 'make install', which works 
ok... But when I try to use the module, running an example (like 
that one found in 'man LWP::Request'), it silently fails.

Does anyone knows what maight be happening?

I'm using:
RedHat Linux 7.1,
perl 5.005_03, 
URI-1.17,
MIME-Base64-2.12,
HTML-Parser-3.25,
libnet-1.0704,
Digest-MD5-1.16,
Crypt-SSLeay-0.31,
IO-Socket-SSL-0.80
(all working OK)

Thanks for your attention,

Diego









nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About