develooper Front page | perl.libwww | Postings from April 2001

Re: WARNING: default LWP install on Mac OS X is bad, Bad, BAD

Thread Previous | Thread Next
From:
Gisle Aas
Date:
April 18, 2001 20:33
Subject:
Re: WARNING: default LWP install on Mac OS X is bad, Bad, BAD
Message ID:
lrsnj5k1ir.fsf@caliper.ActiveState.com
"Joseph N. Hall" <joseph@5sigma.com> writes:

> A default install of LWP on the currently shipping Mac OS X places HEAD in
> /usr/bin/HEAD.  Unfortunately this is a case-insensitive filesystem.  So long
> /usr/bin/head.  I discovered this as I was preparing to install Xfree86 and now
> I have no /usr/bin/head.  Phooey.

Build/install with 'perl Makefile.PL -n' would avoid this problem.

Perhaps it is a good idea to simply set @request_aliases in the
Makefile.PL to be empty if $^O says it is MacOS X.  What is the $^O
value in this case?

Is there any other case-insensitive Unixes?

Another alternative might be to try to open "$Config{scriptdir}/HEAD".
If it works disable installation if this file does not appear to come
from some earlier version of LWP.

Anybody wants to try to provide a patch?

Regards,
Gisle

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About