develooper Front page | perl.libwww | Postings from December 2000

Crypt::SSL Make failure

From:
Ron.W.Flolid
Date:
December 1, 2000 09:52
Subject:
Crypt::SSL Make failure
Message ID:
OFBFE71443.CA1C48C8-ON862569A8.0061B40D@deluxe.com
I realize that this question is more for the OpenSSL formum, but I've not
been able to connect with anyone who has seen this problem or is willing to
help. My problem is that "make" fails for the installation of Crypt::SSL.
(I've included the complete text of the make failure below.) I've tried
previous release of Crypt and all seem to fail with the same symptom of a
library missing for lssl. I've checked my OpenSSL directories and I do have
the libssl.a in the appropriate library. Has anyone else seen this problem?
Would anyone care to lend a suggestion as to how to resolve? Thanks in
advance for any and all suggestions.

# make
mkdir blib
mkdir blib/lib
mkdir blib/lib/Crypt
mkdir blib/arch
mkdir blib/arch/auto
mkdir blib/arch/auto/Crypt
mkdir blib/arch/auto/Crypt/SSLeay
mkdir blib/lib/auto
mkdir blib/lib/auto/Crypt
mkdir blib/lib/auto/Crypt/SSLeay
mkdir blib/man3
cp lib/Crypt/SSLeay/Conn.pm blib/lib/Crypt/SSLeay/Conn.pm
cp lib/Crypt/SSLeay/X509.pm blib/lib/Crypt/SSLeay/X509.pm
cp lib/Crypt/SSLeay/CTX.pm blib/lib/Crypt/SSLeay/CTX.pm
cp lib/Net/SSL.pm blib/lib/Net/SSL.pm
cp lib/Crypt/SSLeay/Err.pm blib/lib/Crypt/SSLeay/Err.pm
cp SSLeay.pm blib/lib/Crypt/SSLeay.pm
cp lib/Crypt/SSLeay/MainContext.pm blib/lib/Crypt/SSLeay/MainContext.pm
        /usr/bin/perl -I/opt/perl5/lib/5.00503/PA-RISC1.1 -I/opt/perl5/lib/5.00503 /opt/perl5/lib/5.00503/ExtUtils/xsubpp  -typemap
/opt/perl5/lib/5.00503/ExtUtils/typemap -typemap typemap SSLeay.xs >xstmp.c && mv xstmp.c SSLeay.c
        cc -c -I/usr/local/ssl/include -Ae -O +Onolimit     -DVERSION=\"0.18\"  -DXS_VERSION=\"0.18\" +z -I/opt/perl5/lib/5.00503/PA-RISC1.1/CORE
SSLeay.c
Running Mkbootstrap for Crypt::SSLeay ()
        chmod 644 SSLeay.bs
        LD_RUN_PATH="/usr/local/ssl/lib" ld -o blib/arch/auto/Crypt/SSLeay/SSLeay.sl  -b -s -a shared SSLeay.o    -L/usr/local/ssl/lib -lssl -lcrypto
ld: Can't find library for -lssl
*** Error exit code 1




Stop.




nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About