develooper Front page | perl.inline | Postings from July 2014

undefined symbol: PL_stack_sp

Thread Next
From:
demerphq
Date:
July 14, 2014 21:08
Subject:
undefined symbol: PL_stack_sp
Message ID:
CANgJU+VwiYx3kNg6R+K2qRro+A3Rr919EY7kQjpTKkRh=CHzYw@mail.gmail.com
Hi,

I've been encountering the error in the subject line when I try to use
Inline::C.

For instance when I build the sample code from the Inline::C docs

use Inline C;
greet('Ingy');
greet(42);
__END__
__C__
void greet(char* name) {
  printf("Hello %s!\n", name);
}

I get the following error:

Had problems bootstrapping Inline module 'FOO_2bd2'

Can't load '/git_tree/perl/Porting/_Inline/lib/auto/FOO_2bd2/FOO_2bd2.so'
for module FOO_2bd2:
/git_tree/perl/Porting/_Inline/lib/auto/FOO_2bd2/FOO_2bd2.so: undefined
symbol: PL_stack_sp at /usr/lib/perl/5.14/DynaLoader.pm line 184.
 at /usr/local/share/perl/5.14.2/Inline.pm line 526.


 at - line 0.
INIT failed--call queue aborted.

I have searched around and there are CPANTester reports of failure due to
this. But I only see one solution, on stackoverflow, that it has to do with
32bit versus 64bit, but it doesnt say what to do to fix and I somehow doubt
it is relevant here.

I did a complete rebuild and test of the latest Inline::C and all tests
passed. So I am a bit confused what I am doing wrong.

My perl version is:

This is perl 5, version 14, subversion 2 (v5.14.2) built for
x86_64-linux-gnu-thread-multi

Complete -V output available on request.

Any ideas on what to do to fix this?

cheers.
Yves

-- 
perl -Mre=debug -e "/just|another|perl|hacker/"

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About