develooper Front page | perl.dbi.users | Postings from January 2013

ANNOUNCE: IBM Informix Database Driver for Perl DBI Version 2013.0118(2013-01-18) released

From:
Jonathan Leffler
Date:
January 19, 2013 05:05
Subject:
ANNOUNCE: IBM Informix Database Driver for Perl DBI Version 2013.0118(2013-01-18) released
Message ID:
CAH+RLGF03-z3E+8c1Q4w93inDM-5znzeefCH_B8nf8Cfgxtc8w@mail.gmail.com
IBM Informix Database Driver for Perl DBI Version 2013.0118 (2013-01-18)
has been uploaded to CPAN.

IBM Informix Database Driver for Perl (also known as DBD::Informix) is
the driver code that enables Perl 5.6.1 or later to access Informix
databases via the DBI module (but if you are not already using Perl
5.10.0 - or any later version - you should be planning to upgrade to
Perl 5.16.2 or later).  You will need the code for DBI version 1.38 or
later as well (v1.623 - or any later version - is recommended).  The
code for DBD::Informix is available for download via:

http://www.perl.org/CPAN/modules/by-category/07_Database_Interfaces
http://dbi.perl.org/

** When you successfully build this module, use the ItWorks (Perl)
** script to report your configuration to the maintenance team (meaning
** Jonathan Leffler) at dbd.informix@gmail.com.
** The ItWorks script does not send email to anybody; you have to do
** that yourself.

New in release 2013.0118:
* Bug fix release.
* Workaround for bug in ESQL/C 3.70 and earlier that generates error -1820
  when reopening a cursor that previously fetched LVARCHAR data.
* Fix for INFORMIXDIR containing Perl regex metacharacters.
* Other minor improvements as documented in the ChangeLog.
* Formal support for ESQL/C 7.x and 8.x (don't ask why the
  current version numbers are smaller) will be dropped after this
  release.  The code won't go away yet, but it is beyond time to
  get off those versions.  ESQL/C 5.20 is nominally supported for
  those still using Informix OnLine 5.20, but there is no
  testing on that platform.

New in release 2011.0612:
* Minor bug fix release.
* Main change is related to Perl internals and avoids the need for
  PERL_POLLUTE.  This change is not visible to users except that Perl
  5.14.x can use the fixed code.
* Fixed problem with string that is not null terminated by ESQL/C library.
* Clean up some 64-bit compilation warnings.
* Build on AIX.
* Evade problem with a DISTINCT type of LVARCHAR with NOT NULL (probably
  ESQL/C bug).
* Fewer versions of Informix products are supported.  You may try
  building DBD::Informix with other versions.  If it works, great; if
  not, please upgrade to a supported Informix version.

Support email address:
* This release is supported by Jonathan Leffler <dbd.informix@gmail.com>.
* You may also report your bugs via the CPAN resolution tracking system:
    http://rt.cpan.org/
* Such bug reports can be sent by email to bug-DBD-Informix@rt.cpan.org;
  they also get sent to dbd.informix@gmail.com, etc.

As always, see the ChangeLog file for details about what has changed.

Jonathan Leffler (jleffler@us.ibm.com, jonathan.leffler@gmail.com)

@(#)$Id: Announce,v 2013.2 2013/01/18 19:55:18 jleffler Exp $


-- 
Jonathan Leffler <jonathan.leffler@gmail.com>  #include <disclaimer.h>
Guardian of DBD::Informix - v2011.0612 - http://dbi.perl.org
"Blessed are we who can laugh at ourselves, for we shall never cease to be
amused."



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About