develooper Front page | perl.beginners | Postings from April 2002

module installation error

From:
Shah, Urmil
Date:
April 26, 2002 12:23
Subject:
module installation error
Message ID:
87EA450621E2D211B6EE0000F8CD2957109B35BF@dlee07.itg.ti.com
I am trying to install perl Chart::Plot module in my home directory since i
dont have the right to install in the server.
This module is dependent on GD module so i am trying to install GD-1.38
first. but it gives me following error

>perl Makefile.PL PREFIX=/usr/home/myname/usr/local
NOTICE: This module requires libgd 1.8.4 or higher (shared library version
4.X).

Please choose the features that match how libgd was built:
Build JPEG support? [y] y
Build FreeType support? [y] y
Build XPM support? [y] y
Build GIF support (for patched versions of gd)? [n] n

If you experience compile problems, please check the @INC, @LIBPATH and
@LIBS
arrays defined in Makefile.PL and manually adjust, if necessary.

'ABSTRACT' is not a known MakeMaker parameter name.
'AUTHOR' is not a known MakeMaker parameter name.
'CAPI' is not a known MakeMaker parameter name.
Warning (will try anyway): No library found for -lgd
Warning (will try anyway): No library found for -lfreetype
Writing Makefile for GD

 >make
cc -c -I/usr/local/include -I/usr/local/include/gd -I/usr/local/include -O
-DVERSION=\"1.38\" -DXS_VERSION=\"1.38\" -Kpic
-I/apps/perl5.003/lib/sun4-solaris/5.003/CORE -DHAVE_JPEG -DHAVE_TTF
-DHAVE_XPM GD.c
/usr/ucb/cc:  language optional software package not installed
make: *** [GD.o] Error 1


**** Now if i use gcc instead of cc it gives me different error


>make CC=gcc
gcc -c -I/usr/local/include -I/usr/local/include/gd -I/usr/local/include -O
-DVERSION=\"1.38\" -DXS_VERSION=\"1.38\" -Kpic
-I/apps/perl5.003/lib/sun4-solaris/5.003/CORE -DHAVE_JPEG -DHAVE_TTF
-DHAVE_XPM GD.c
gcc: unrecognized option `-Kpic'
In file included from
/apps/perl5.003/lib/sun4-solaris/5.003/CORE/perl.h:125,
                 from GD.c:13:
/usr/local/include/sys/param.h:181: warning: `NBBY' redefined
/usr/include/sys/select.h:56: warning: this is the location of the previous
definition
GD.c:15: gd.h: No such file or directory
GD.c:24: perlio.h: No such file or directory
make: *** [GD.o] Error 1


Does anyone know what the problem is and how can i fix it.


Thanks
Urmil




nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About