develooper Front page | perl.beginners.cgi | Postings from November 2014

Re: WWW::Mechanize question

Thread Previous | Thread Next
From:
Patton, Billy N
Date:
November 3, 2014 16:42
Subject:
Re: WWW::Mechanize question
Message ID:
CACCF383-352D-4951-BEE2-9606BC4A9FA0@west.com
I’ve gotten everything copied and working from the Chrome, but when I execute my test script I get :
ok 1 - In sub main::login
ok 2 -                    : 49   : Credentials passed ok
Error GETing http://cportal-test.dfw0.hypercube-llc.com/html/cp.cgi: Authorization Required at /System/Library/Perl/Extras/5.18/LWP/Authen/Basic.pm line 56.

Here is my .htaccess :
AuthType Basic
AuthName "HyperCube Customer Portal requires a username and password"
AuthUserFile /var/www/passwords/cportal.passwd
Require valid-user


login/password is the same for all versions.


I know it is something just one step away, can’t get what it is?


> On Nov 3, 2014, at 8:50 AM, John SJ Anderson <genehack@genehack.org> wrote:
> 
> Hi Billy -
> 
> Are any of the forms in the templates displayed conditionally? (I.e.,
> are there forms inside IF blocks in the templates.)
> 
> If not -- if all the forms are always shown -- then yes, the numbers
> should be stable.
> 
> My suggestion would be to just add unique identifiers to the forms,
> because then you won't have to worry about it.
> 
> chrs,
> john.
> 
> 
> On Mon, Nov 3, 2014 at 6:41 AM, Patton, Billy N <billy.patton@h3net.com> wrote:
>> I’ve inherited an app that uses templates.
>> Most of the template contain multiple forms and tables within and buttons within that.
>> The order of the forms I can get from the template, most are not named forms so I have to get them with form_number(#)
>> 
>> Question:
>>        Can I depend on the form number being the same each time it is loaded?
>>        Or will it change.


Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About