develooper Front page | perl.perl5.porters | Postings from September 2011

RE: Speak up now about your use of EBCDIC or WE WILL REMOVE IT in afuture release of Perl

Thread Previous | Thread Next
From:
Dean, Sandy
Date:
September 30, 2011 06:42
Subject:
RE: Speak up now about your use of EBCDIC or WE WILL REMOVE IT in afuture release of Perl
Message ID:
711631D4269440489E56F4B2B5C3DF77062267@DLEE09.ent.ti.com
Here is the question I asked IBM:

What is IBM's stance on supporting perl from this point 
forward? I am a heavy user of perl in the USS environment, and would    
need to redesign my applications if perl were to go unsupported.        
                                                                        
The open source group currently supporting perl on z/os is unable to    
continue because as things break (which they have), they have no        
platform on which to test, and no z/os developers who have the time to  
step up to the task.                                                    
                                                                        
It is looking like IBM will need to officially support this product on  
USS or it is going to die a painful death.                              
                                                                        
Please let me know your thoughts.

Here is their response:

IBM will continue to support the Ported Tools version of Perl for the   
forseeable future. It's separate from the open source code base.        
                                                                       .
If and when the decision is made to support a newer version of Perl, IBM
will tackle the EBCDIC aspects.         

                                      

-----Original Message-----
From: Dean, Sandy 
Sent: Wednesday, September 28, 2011 6:41 AM
To: Nicholas Clark; Terwedow, Egon (E.)
Cc: Craig A. Berry; Jesse Vincent; Perl5 Porters; perl-mvs@perl.org
Subject: RE: Speak up now about your use of EBCDIC or WE WILL REMOVE IT in a future release of Perl

I will ask IBM.

Sandy Dean

-----Original Message-----
From: Nicholas Clark [mailto:nick@flirble.org] On Behalf Of Nicholas Clark
Sent: Monday, September 26, 2011 2:47 PM
To: Terwedow, Egon (E.)
Cc: Craig A. Berry; Jesse Vincent; Perl5 Porters; perl-mvs@perl.org
Subject: Re: Speak up now about your use of EBCDIC or WE WILL REMOVE IT in a future release of Perl

On Mon, Sep 26, 2011 at 06:41:03AM +0000, Terwedow, Egon (E.) wrote:
> Hello, 
> 
> We still customize Perl in our USS environment and we use it in a few of our web interfaces. I would appreciate if the open source community will continue to support the product.

We simply aren't in a position to support the product, unaided.

None of the current core perl developers have access to any EBCDIC platform
since they became core developers. Those core developers that did have
access did so nearly 10 years ago, and have either moved to other projects
or died. IBM does not offer any sort access to EBCDIC based systems for us
to test things.

> This is not highest priority and we do not need latest releases in line with the rest of the Perl community but it would be important to continue the IBM open source commitment to have Perl on the list of supported products. 
> 
> Please let me know if you decide to stop the support for Perl so that I can inform the user community in my company that this is no longer a viable solution. 

De facto there is already no support from the community for Perl on EBCDIC
platforms, because the community has *no* access to them, or proxy access
via the "remote hands" of volunteers.

Note also that removing the EBCDIC-related code from the current version in
no way actually changes your current situation. Nor does leaving it in.

Removing it won't overnight stop the code you have from working.
Leaving it in won't make the current version work on EBCDIC.

Either way, your code is just as supported tomorrow as it was yesterday.
ie it's not. (Unless you have a support contract from IBM that I'm not
aware of.)

We've already dropped support for 5.8.x and 5.10.x, across the board.
(I'm guessing that EBCDIC users are on 5.8.x or earlier)

Really we need help (money alone won't cut it, unless it's enough to *buy*,
host and maintain an EBCDIC system) from either EBCDIC users who value Perl,
or IBM, as the vendor whose commercial platform benefits from having Perl
working on it.


It would be helpful to us, if EBCDIC users, as IBM customers, were to ask
IBM how IBM plan to help support Perl on EBCDIC.

Nicholas Clark

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About