develooper Front page | perl.perl5.porters | Postings from December 2007

kurila 1.6 released (not featuring AUTOLOAD)

Thread Next
From:
Gerard Goossen
Date:
December 4, 2007 03:56
Subject:
kurila 1.6 released (not featuring AUTOLOAD)
Message ID:
20071204120136.GU5329@ostwald
kurila 1.6 released


Perl Kurila 1.6 has no more AUTOLOAD.

Highlights:
+ An error is raised if an undefined subroutine is called (Any 
  AUTOLOAD subroutine is ignored).
+ v-syntax create 'version' objects.
+ v-syntax must be used to do version checks

Known bugs:
+ Documentation
+ Limited platform support

http://dev.tty.nl/static/kurila/doc/pod/kurila16delta.html
has a more complete list of the changes.



kurila 1.6 is released together with more then hundred modules,
available together at:
http://dev.tty.nl/static/kurila/kurila-bundle-1.6.tar.gz

kurila 1.6 without the CPAN modules is available at:
http://dev.tty.nl/static/kurila/kurila-1.6_0.tar.gz
And should become available on CPAN.
Or use git to get the latest version:
git-clone git://dev.tty.nl/perl



Perl Kurila is a dialect of Perl. With Perl 5 as ancestor it has a
solid base, but without the backwards compatibility
requirement of Perl 5, it is free to evolve into new directions.

A longer explanation of kurila is available at
http://dev.tty.nl/static/kurila/doc/pod/kurilaintro.html



Standing on the shoulders of a red giant to face the future.

-- 
Gerard Goossen
TTY Internet Solutions


Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About