develooper Front page | perl.dbi.users | Postings from August 2001

Can't locate DBD/Oracle.pm

Thread Next
From:
Veeresh
Date:
August 8, 2001 21:33
Subject:
Can't locate DBD/Oracle.pm
Message ID:
000e01c1208c$e5d84230$490110ac@ncmr.co.in
Hi All,
I'm using the Oracle 8.1.6 version. I was trying to run the Perl script i got this error.

install_driver(Oracle) failed: Can't locate DBD/Oracle.pm in @INC (@INC contains: /opt/apps/portal/pin16/opt/portal/6.0/lib /opt/apps/portal/pin16/opt/portal/6.0/lib/perl5/sun4-solaris/5.00503 /opt/apps/portal/pin16/opt/portal/6.0/lib/perl5 /opt/apps/portal/pin16/opt/portal/6.0/lib/perl5/DBI-1.19 /opt/apps/portal/pin16/opt/portal/6.0/lib/perl5/DBD-Oracle-1.07 /opt/portal/6.0/lib/perl5/sun4-solaris/5.00503 /opt/portal/6.0/lib/perl5 /opt/portal/6.0/lib/perl5/site_perl/sun4-solaris /opt/portal/6.0/lib .) at (eval 1) line 3, <STDIN> chunk 6.
Perhaps the DBD::Oracle perl module hasn't been fully installed,
or perhaps the capitalisation of 'Oracle' isn't right.
Available drivers: ADO, ExampleP, Multiplex, Proxy.
 at cust.pl line 113

Then  I downloaded DBD-Oracle-1.07 from "cpan.org".
then i did 
make 
make test

then I got this error

ERL_DL_NONLAZY=1 /opt/apps/portal/pin16/opt/portal/6.0/bin/perl -Iblib/arch -Iblib/lib -I/opt/portal/6.0/lib/perl5/sun4-solaris/5.00503 -I/opt/portal/6.0/lib/perl5 -e 'use Test::Harness qw(&runtests $verbose); $verbose=0; runtests @ARGV;' t/*.t
t/base..............You must install a Solaris patch to run this version of the Java runtime.
Please see the README and release notes for more information.
Exiting.
dubious
        Test returned status 1 (wstat 256, 0x100)
DIED. FAILED tests 4-5
        Failed 2/5 tests, 60.00% okay
t/general...........You must install a Solaris patch to run this version of the Java runtime.
Please see the README and release notes for more information.
Exiting.
dubious
        Test returned status 1 (wstat 256, 0x100)
t/long..............You must install a Solaris patch to run this version of the Java runtime.
Please see the README and release notes for more information.
Exiting.
dubious
        Test returned status 1 (wstat 256, 0x100)
t/plsql.............You must install a Solaris patch to run this version of the Java runtime.
Please see the README and release notes for more information.
Exiting.
dubious
        Test returned status 1 (wstat 256, 0x100)
t/reauth............skipping test on this platform
Failed Test  Status Wstat Total Fail  Failed  List of failed
-------------------------------------------------------------------------------
t/base.t          1   256     5    2  40,00%  4-5
t/general.t       1   256    ??   ??       %  ??
t/long.t          1   256    ??   ??       %  ??
t/plsql.t         1   256    ??   ??       %  ??
1 test skipped.
Failed 4/5 test scripts, 20.00% okay. 2/5 subtests failed, 60.00% okay.
make: *** [test_dynamic] Error 29


this is th eresult of  
make perl

ld: fatal: file /opt/apps/oracle/product/8.1.6/rdbms/lib/libskgxpd..a: cannot open file: No such file or directory
ld: fatal: file /opt/apps/oracle/product/8.1.6/rdbms/lib/libskgxpu..a: cannot open file: No such file or directory
ld: fatal: file /opt/apps/oracle/product/8.1.6/rdbms/lib/libskgxpt..a: cannot open file: No such file or directory
ld: fatal: File processing errors. No output written to perl
*** Error code 1
make: Fatal error: Command failed for target `perl'
Current working directory /opt/apps/portal/pin16/opt/portal/6.0/lib/perl5/DBD-Oracle-1.08
make: *** [perl] Error 1


I appreciate i fany body can help in this regard.


Regards,
Veeresh.


Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About