develooper Front page | perl.cpan.testers.discuss | Postings from June 2013

Re: Is this tester configured incorrectly?

Thread Previous
From:
Chad Thomas
Date:
June 23, 2013 22:53
Subject:
Re: Is this tester configured incorrectly?
Message ID:
CAJrs5JajOXUbS4B5kwyCfH9fqABF-7Ou6Wywr_B4oim5k_F0Fg@mail.gmail.com
David,

Thanks for catching that. I just recently setup the smoker and noticed it
generated a slew of unknowns and couldn't figure out why. I'd been trying
to view the reports but it seems to take quite a while for them to show up
on the site.

Thanks,
Chad Thomas


On Sun, Jun 23, 2013 at 6:43 PM, David Oswald <daoswald@gmail.com> wrote:

> Here's a sample report:
>
> http://www.cpantesters.org/cpan/report/009237f6-db57-11e2-8928-35f7705b4af5
>
> This line is suspect:
>
>  PATH = /home/perl1/.perlbrew/libs/perl-5.12.5@smoke0
> /bin:/home/perl1/perl5/perlbrew/bin:/home/perl1/perl5/perlbrew/perls/perl-5.12.5/bin:$PATH
>
> Notice it ends in $PATH. That was probably meant to expand to the old
> value of the PATH env var, but it doesn't. As a result, /bin and
> /usr/bin are not in the path.
>
> It could be that I'm misreading the report, and consequently
> misdiagnosing, but if it's configured incorrectly I suspect there are
> a lot of "UNKNOWN" reports from this smoker recently.
>
>
>
> --
>
> David Oswald
> daoswald@gmail.com
> davido@cpan.org
>


Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About