develooper Front page | perl.cpan.discuss | Postings from April 2012

cpan msg: 'YAML' not installed.../install YAML / YAML is up to date(0.80)' ????

From:
Linda Walsh
Date:
April 13, 2012 15:14
Subject:
cpan msg: 'YAML' not installed.../install YAML / YAML is up to date(0.80)' ????
Message ID:
4F88A556.2040209@tlinx.org



I see this message in my cpan builds that doesn't make sense.

On one hand I see:
Checking if your kit is complete...
Looks good
Writing Makefile for IO::Pty::Easy
Writing MYMETA.yml and MYMETA.json
cp lib/IO/Pty/Easy.pm blib/lib/IO/Pty/Easy.pm
Manifying blib/man3/IO::Pty::Easy.3pm
  DOY/IO-Pty-Easy-0.09.tar.gz
  /usr/bin/make -j -j   -- OK
'YAML' not installed, will not store persistent state
---------------------
I thought YAML should be installed... so... I try installing it:


 > install YAML
YAML is up to date (0.80).

So What's up ??  I've seen this before on other installs as well...

YAML is installed/uptodate, but it's not installed?

I did a 'force install' on YAML to force it to 'reinstall', -- same message.

Should I be getting that message?





nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About